Community Forum

Magtek iPad Swiper - not reading cards

We’re in the process of going live with Wine Direct and experiencing significant issues with two Magtek cDynamo iPad enclosures with the credit card swiper on the side. When a card is swiped it does not recognize it in the POS app. Various solutions seem to work, however, none of them work consistently and these solutions shouldn’t be required for every second transaction:

  1. clearing the cart and restarting the transaction
  2. logging out of the POS and re-entering the order
  3. closing the POS app and restarting
  4. #3 plus running the magtek test application
  5. turning off the iPad

Any help that can be provided on these issues are greatly appreciated!

@magtek; @cDynamo

We also have that issue. It also affects charging. From my time with support, I have learned that this is an issue with iOS.

It seems to be a security feature in iOS, that disables USB devices when the device is idle. It’s supposed to reconnect when unlocked, but that doesn’t always happen. I was told this will be fixed in an upcoming iOS update. This was at least 6 months ago.

Our temporary fix is to reboot the iPad. That almost always fixes the problem. Also, setting auto-lock to “Never” helps prevent this from occurring, though it does still occur occasionally.

We had similar issues. We discover two things that has helped…almost 100%. Always boot (turn on) the ipad with the reader attached. We deal with this due to the charging process. The ipad seems to charge faster and more reliably with the apple charger.

As for the 2nd fix, turn your Auto-Lock aka ‘Screen Saver’ to NEVER. It seem that the ipad looses connectivity to these devices when it locks the screen or goes to sleep for saving power.