Community Forum

Admin Panel - Print Receipt Defaulting to PDF save in Google Chrome

Has anyone experienced/fixed this? I have checked everything and it only occurs with the Vin65 document. My old desktop started doing the same thing but I got a new one. Unfortunately now someone else’s desktop is doing the same thing… No option to choose printer Just jumps right to the title and location for saving the PDF.
Thank you!

Could you post a screenshot in of the print dialogue?

Also, I’ve seen this happen before, check the Device Settings on the iPad, I’ve seen that mysteriously toggle away from the receipt printer.

I think that might be the problem, Ed. If they’ve enabled silent printing or kiosk mode, they won’t see that dialog at all. I think we just need to do the opposite of what’s in this doc:

https://mycartpos.zendesk.com/hc/en-us/articles/200868343-Enable-kiosk-printing-print-automatically-for-Google-Chrome-on-Windows

Thanks guys, but this is a Windows Desktop with the problem.

Yep, the link I sent is for a desktop. I think your instance of Chrome is set to not show the print dialog for one reason or another. Reversing those setup instructions (from the link above) would make it so that you see the Print Dialog again so you can change your printer from PDF to a real printer.

You also might be able to just change your default printer in Windows settings. Just search for printer in the search bar (in the bottom left of the screen), right click on the real printer, and select “Set Printer as Default” or something along those lines.

He is not using a Google Chrome shortcut so I don’t think it can be the kiosk printing issue? Everything was working last week, no set ups were changed.

Just make a Chrome Extension for this, @Karson

We select print receipt and it jumps straight there… Anything else we try to print from the browser works normally.

Can you post a screenshot of your installed printers?

Are you able to print to the actual printer if you select it? Chrome sets the default printer to the last location you sent it too, so if others are using the computer, or you are often printing in PDF form then that may be a cause.

Currently Chrome does not provide APIs for sending to individual printers, so we cant control this :frowning:

The only screens that we have available are the two above, no way to choose a printer. The Vin65 site is the only one doing this, all others give us the normal printer dialogue.

Its very strange…

Is this happening in any other browsers? Or just Chrome.

If you’re just on the Vin65 dashboard, and you hit control + p, and try to print the page, does it show the correct printer in that scenario?

Hi Karson + p in chrome goes straight to the screen shot above. We just tried Firefox and it does the same thing, straight to PDF save.

We are still having this problem …

This is still occurring with Jacob’s PC and mine started doing it Friday as well. I need to print receipts on a regular basis. No one else has experienced this?

@Zach thank you for fixing this!!!

@Erica We fixed it! As in all of us, together, right now! Yay!

All, so the issue in this case (and I’ve experienced this myself) is:

This isn’t anything to do with printers in this case. We were all on the wrong trail (including me).

When you download a .pdf (or any file), the file explorer in Windows or Mac will append the name the file with the next number in the sequence up to 100. For example, when you download an Invoice in Vin65 from Store > (click on order) > Actions > Print Invoice, the name of the file is Order.pdf. If you download another Invoice, it’ll be called Order (1).pdf. Downloading Invoices will continue to function like this until you reach Order (100).pdf. Then, the system, for whatever reason, will prompt you to save the file with a new name every time instead.

This happens with every report and download in Vin65 (and, frankly, everywhere else on the interweb) when a file of the same name is downloaded again.

The lesson learned here is to clean out your Downloads folder every once in a while. Just delete all the Order (###).pdf files and you’ll be good as new again.

PS Big thanks to @brennan for the assist!

1 Like

@Karson come check out the answer here. Maybe the .pdf name should be Order [Order Number].pdf so this never happens again. Just a thought!

3 Likes